CVE-2014-8098 (retired)

Priority
Description
The GLX extension in XFree86 4.0, X.Org X Window System (aka X11 or X)
X11R6.7, and X.Org Server (aka xserver and xorg-server) before 1.16.3
allows remote authenticated users to cause a denial of service
(out-of-bounds read or write) or possibly execute arbitrary code via a
crafted length or index value to the (1) __glXDisp_Render, (2)
__glXDisp_RenderLarge, (3) __glXDispSwap_VendorPrivate, (4)
__glXDispSwap_VendorPrivateWithReply, (5) set_client_info, (6)
__glXDispSwap_SetClientInfoARB, (7) DoSwapInterval, (8) DoGetProgramString,
(9) DoGetString, (10) __glXDispSwap_RenderMode, (11)
__glXDisp_GetCompressedTexImage, (12) __glXDispSwap_GetCompressedTexImage,
(13) __glXDisp_FeedbackBuffer, (14) __glXDispSwap_FeedbackBuffer, (15)
__glXDisp_SelectBuffer, (16) __glXDispSwap_SelectBuffer, (17)
__glXDisp_Flush, (18) __glXDispSwap_Flush, (19) __glXDisp_Finish, (20)
__glXDispSwap_Finish, (21) __glXDisp_ReadPixels, (22)
__glXDispSwap_ReadPixels, (23) __glXDisp_GetTexImage, (24)
__glXDispSwap_GetTexImage, (25) __glXDisp_GetPolygonStipple, (26)
__glXDispSwap_GetPolygonStipple, (27) __glXDisp_GetSeparableFilter, (28)
__glXDisp_GetSeparableFilterEXT, (29) __glXDisp_GetConvolutionFilter, (30)
__glXDisp_GetConvolutionFilterEXT, (31) __glXDisp_GetHistogram, (32)
__glXDisp_GetHistogramEXT, (33) __glXDisp_GetMinmax, (34)
__glXDisp_GetMinmaxEXT, (35) __glXDisp_GetColorTable, (36)
__glXDisp_GetColorTableSGI, (37) GetSeparableFilter, (38)
GetConvolutionFilter, (39) GetHistogram, (40) GetMinmax, or (41)
GetColorTable function.
Assigned-to
mdeslaur
Package
Upstream:released (304.125)
Ubuntu 14.04 LTS (Trusty Tahr):released (304.125-0ubuntu0.0.1)
Package
Upstream:released (304.125)
Ubuntu 14.04 LTS (Trusty Tahr):released (304.125-0ubuntu0.0.1)
Package
Upstream:released (331.113)
Ubuntu 14.04 LTS (Trusty Tahr):released (331.113-0ubuntu0.0.4)
Package
Upstream:released (331.113)
Ubuntu 14.04 LTS (Trusty Tahr):released (331.113-0ubuntu0.0.4)
Package
Upstream:released (2:1.16.2.901-1)
Ubuntu 14.04 LTS (Trusty Tahr):released (2:1.15.1-0ubuntu2.4)
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
More Information

Updated: 2019-03-26 12:13:38 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)