CVE-2014-7845

Priority
Description
The generate_password function in Moodle through 2.4.11, 2.5.x before
2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide a
sufficient number of possible temporary passwords, which allows remote
attackers to obtain access via a brute-force attack.
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.7.5+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.7.5+dfsg-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.7.5+dfsg-1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.7.5+dfsg-1)
More Information

Updated: 2019-01-14 21:16:06 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)