CVE-2014-7835 (retired)

Priority
Description
webservice/upload.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3
does not ensure that a file upload is for a private or draft area, which
allows remote authenticated users to upload files containing JavaScript,
and consequently conduct cross-site scripting (XSS) attacks, by specifying
the profile-picture area.
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.7.5+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.7.5+dfsg-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.7.5+dfsg-1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.7.5+dfsg-1)
Ubuntu 19.10 (Eoan):not-affected (2.7.5+dfsg-1)
More Information

Updated: 2019-04-26 14:33:53 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)