CVE-2014-7191

Priority
Description
The qs module before 1.0.0 in Node.js does not call the compact function
for array data, which allows remote attackers to cause a denial of service
(memory consumption) by using a large index value to create a sparse array.
Package
Upstream:released (1.0.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.2.4-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.2.4-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.2.4-1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.2.4-1)
More Information

Updated: 2019-01-14 21:15:59 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)