CVE-2014-6396 (retired)

Priority
Description
The dissector_postgresql function in dissectors/ec_postgresql.c in Ettercap
before 0.8.1 allows remote attackers to cause a denial of service and
possibly execute arbitrary code via a crafted password length, which
triggers a 0 character to be written to an arbitrary memory location.
Package
Upstream:released (1:0.8.1-3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1:0.8.1-3)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:0.8.1-3)
Ubuntu 19.04 (Disco Dingo):not-affected (1:0.8.1-3)
Ubuntu 19.10 (Eoan):not-affected (1:0.8.1-3)
More Information

Updated: 2019-08-23 09:04:04 UTC (commit 436fd4ed4cf0038ddd382cb8649607ace163dda7)