CVE-2014-6395

Priority
Description
Heap-based buffer overflow in the dissector_postgresql function in
dissectors/ec_postgresql.c in Ettercap before 0.8.1 allows remote attackers
to cause a denial of service or possibly execute arbitrary code via a
crafted password length value that is inconsistent with the actual length
of the password.
Package
Upstream:released (1:0.8.1-3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1:0.8.1-3)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:0.8.1-3)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1:0.8.1-3)
Ubuntu 19.04 (Disco Dingo):not-affected (1:0.8.1-3)
More Information

Updated: 2019-01-14 21:15:58 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)