CVE-2014-5354 (retired)

Priority
Description
plugins/kdb/ldap/libkdb_ldap/ldap_principal2.c in MIT Kerberos 5 (aka krb5)
1.12.x and 1.13.x before 1.13.1, when the KDC uses LDAP, allows remote
authenticated users to cause a denial of service (NULL pointer dereference
and daemon crash) by creating a database entry for a keyless principal, as
demonstrated by a kadmin "add_principal -nokey" or "purgekeys -all"
command.
Assigned-to
mdeslaur
Notes
Package
Source: krb5 (LP Ubuntu Debian)
Upstream:released (1.12.1+dfsg-16)
Patches:
Upstream:https://github.com/krb5/krb5/commit/04038bf3633c4b909b5ded3072dc88c8c419bf16
Upstream:https://github.com/krb5/krb5/commit/877ad027ca2103f3ac2f581451fdd347a76b8981 (1.12)
Binaries built from this source package are in universe and so are supported by the community. For more details see https://wiki.ubuntu.com/SecurityTeam/FAQ#Official_Support
More Information

Updated: 2019-10-09 07:50:54 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)