CVE-2014-5031 (retired)

Priority
Description
The web interface in CUPS before 2.0 does not check that files have
world-readable permissions, which allows remote attackers to obtains
sensitive information via unspecified vectors.
Assigned-to
mdeslaur
Notes
mdeslaurThe patch below introduces a regression preventing the web
interface from being able to read log files. (See comments in
bug 4455.)
Package
Source: cups (LP Ubuntu Debian)
Upstream:released (1.7.4-5)
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (1.7.5-1)
Patches:
Upstream:https://cups.org/strfiles.php/3371/str4455-1.7.patch
More Information

Updated: 2019-10-09 07:50:49 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)