CVE-2014-4967

Priority
Description
Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow
remote attackers to execute arbitrary code by leveraging access to an
Ansible managed host and providing a crafted fact, as demonstrated by a
fact with (1) a trailing " src=" clause, (2) a trailing " temp=" clause, or
(3) a trailing " validate=" clause accompanied by a shell command.
Notes
Package
Upstream:released (1.6.8+dfsg-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.0.0.2-2ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.5.1+dfsg-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (2.6.1+dfsg-1)
Ubuntu 20.04 (Focal Fossa):not-affected (2.6.1+dfsg-1)
Patches:
Upstream:https://github.com/ansible/ansible/commit/84759faa0950146a6bae8452580b4a4cede6d871
More Information

Updated: 2020-04-24 03:17:14 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)