CVE-2014-4966

Priority
Description
Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup"
substrings, and does not prevent remote data with "{{" substrings, which
allows remote attackers to execute arbitrary code via (1) crafted
lookup('pipe') calls or (2) crafted Jinja2 data.
Notes
Package
Upstream:released (1.6.8+dfsg-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 19.10 (Eoan Ermine):not-affected
Ubuntu 20.04 (Focal Fossa):not-affected
Patches:
Upstream:https://github.com/ansible/ansible/commit/84759faa0950146a6bae8452580b4a4cede6d871
More Information

Updated: 2020-04-24 03:17:14 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)