CVE-2014-4502

Priority
Description
Multiple heap-based buffer overflows in the parse_notify function in
sgminer before 4.2.2, cgminer before 4.3.5, and BFGMiner before 4.1.0 allow
remote pool servers to have unspecified impact via a (1) large or (2)
negative value in the Extranonc2_size parameter in a mining.subscribe
response and a crafted mining.notify request.
Package
Upstream:released (4.1.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 18.10 (Cosmic Cuttlefish):needed
Ubuntu 19.04 (Disco Dingo):DNE
Patches:
Upstream:https://github.com/luke-jr/bfgminer/commit/ff7f30129f15f7a2213f8ced0cd65c9a331493d9
More Information

Updated: 2019-01-14 21:15:47 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)