CVE-2014-4501

Priority
Description
Multiple stack-based buffer overflows in sgminer before 4.2.2, cgminer
before 4.3.5, and BFGMiner before 3.3.0 allow remote pool servers to have
unspecified impact via a long URL in a client.reconnect stratum message to
the (1) extract_sockaddr or (2) parse_reconnect functions in util.c.
Package
Upstream:released (3.3.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 18.10 (Cosmic Cuttlefish):needed
Ubuntu 19.04 (Disco Dingo):DNE
Patches:
Upstream:https://github.com/luke-jr/bfgminer/commit/c80ad8548251eb0e15329fc240c89070640c9d79
More Information

Updated: 2019-01-14 21:15:47 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)