CVE-2014-4345 (retired)

Priority
Description
Off-by-one error in the krb5_encode_krbsecretkey function in
plugins/kdb/ldap/libkdb_ldap/ldap_principal2.c in the LDAP KDB module in
kadmind in MIT Kerberos 5 (aka krb5) 1.6.x through 1.11.x before 1.11.6 and
1.12.x before 1.12.2 allows remote authenticated users to cause a denial of
service (buffer overflow) or possibly execute arbitrary code via a series
of "cpw -keepold" commands.
Notes
 jdstrand> krb5-admin-server
Assigned-to
mdeslaur
Package
Source: krb5 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (1.12.1+dfsg-7)
Patches:
Upstream:https://github.com/krb5/krb5/commit/81c332e29f10887c6b9deb065f81ba259f4c7e03
Binaries built from this source package are in universe and so are supported by the community. For more details see https://wiki.ubuntu.com/SecurityTeam/FAQ#Official_Support
More Information

Updated: 2019-09-19 15:49:38 UTC (commit d32ebc32606b9517c6fa7d65a15441e2a57a6de5)