CVE-2014-3776

Priority
Description
Buffer overflow in the "read-u8vector!" procedure in the srfi-4 unit in
CHICKEN stable 4.8.0.7 and development snapshots before 4.9.1 allows remote
attackers to cause a denial of service (memory corruption and application
crash) and possibly execute arbitrary code via a "#f" value in the NUM
argument.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (4.9.0.1-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (4.10.0-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (4.10.0-1)
Ubuntu 19.04 (Disco Dingo):not-affected (4.10.0-1)
More Information

Updated: 2019-01-14 21:15:41 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)