CVE-2014-3775

Priority
Description
libgadu before 1.11.4 and 1.12.0 before 1.12.0-rc3, as used in Pidgin and
other products, allows remote Gadu-Gadu file relay servers to cause a
denial of service (memory overwrite) or possibly execute arbitrary code via
a crafted message.
Assigned-to
mdeslaur
Notes
Package
Upstream:released (1:1.12.0~rc3-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [1:1.11.1-1ubuntu0.2])
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1:1.12.0~rc3-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:1.12.0~rc3-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (1:1.12.0~rc3-1)
Patches:
Upstream:https://github.com/wojtekka/libgadu/commit/f45ff34dfe2edab54d6fa185e8b87246ab100bd4
Upstream:https://github.com/wojtekka/libgadu/commit/0db17ad635b07566d4e53a773919c16472341966
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [1:2.10.3-0ubuntu1.5])
Ubuntu 14.04 ESM (Trusty Tahr):released (1:2.10.9-0ubuntu3.1)
Ubuntu 16.04 LTS (Xenial Xerus):released (1:2.10.9-0ubuntu4)
Ubuntu 18.04 LTS (Bionic Beaver):released (1:2.10.9-0ubuntu4)
Ubuntu 19.10 (Eoan Ermine):released (1:2.10.9-0ubuntu4)
Patches:
Upstream:https://hg.pidgin.im/pidgin/main/rev/fd11790cc4d6
More Information

Updated: 2020-05-07 18:36:31 UTC (commit 3db3e0dddc92f0ed79599b5949ba82bc7a3031ed)