CVE-2014-3634

Priority
Description
rsyslog before 7.6.6 and 8.x before 8.4.1 and sysklogd 1.5 and earlier
allows remote attackers to cause a denial of service (crash), possibly
execute arbitrary code, or have other unspecified impact via a crafted
priority (PRI) value that triggers an out-of-bounds array access.
Notes
 mdeslaur> also see followup issue CVE-2014-3683
Assigned-to
mdeslaur
Package
Upstream:released (8.4.1,7.6.6)
Ubuntu 12.04 ESM (Precise Pangolin):released (5.8.6-1ubuntu8.9)
Ubuntu 14.04 LTS (Trusty Tahr):released (7.4.4-1ubuntu2.3)
Ubuntu 16.04 LTS (Xenial Xerus):released (7.4.4-1ubuntu11)
Patches:
Upstream:http://www.rsyslog.com/files/download/rsyslog/pri-vuln.tar.gz
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
More Information

Updated: 2019-03-19 12:14:52 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)