CVE-2014-3617

Priority
Description
The forum_print_latest_discussions function in mod/forum/lib.php in Moodle
through 2.4.11, 2.5.x before 2.5.8, 2.6.x before 2.6.5, and 2.7.x before
2.7.2 allows remote authenticated users to bypass the individual
answer-posting requirement without the mod/forum:viewqandawithoutposting
capability, and discover an author's username, by leveraging the student
role and visiting a Q&A forum.
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.7.5+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.7.5+dfsg-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.7.5+dfsg-1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.7.5+dfsg-1)
Patches:
Upstream:http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-46619
More Information

Updated: 2019-01-14 21:15:40 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)