CVE-2014-3587

Priority
Description
Integer overflow in the cdf_read_property_info function in cdf.c in file
through 5.19, as used in the Fileinfo component in PHP before 5.4.32 and
5.5.x before 5.5.16, allows remote attackers to cause a denial of service
(application crash) via a crafted CDF file. NOTE: this vulnerability
exists because of an incomplete fix for CVE-2012-1571.
Assigned-to
sarnold
Package
Source: file (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):released (1:5.14-2ubuntu3.2)
Package
Source: php5 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):released (5.5.9+dfsg-1ubuntu4.4)
Patches:
Upstream:https://github.com/php/php-src/commit/7ba1409a1aee5925180de546057ddd84ff267947
More Information

Updated: 2019-03-19 12:14:50 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)