CVE-2014-3566 (retired)

Priority
Description
The SSL protocol 3.0, as used in OpenSSL through 1.0.1i and other products,
uses nondeterministic CBC padding, which makes it easier for
man-in-the-middle attackers to obtain cleartext data via a padding-oracle
attack, aka the "POODLE" issue.
Assigned-to
mdeslaur
Notes
mdeslaurWe recommend disabling SSLv3 on servers, if possible.

Community-provided information on disabling SSLv3 can be found
here:

http://askubuntu.com/a/537196

SANS provided information on disabling SSLv3 can be found here:
https://isc.sans.edu/forums/diary/POODLE+Turning+off+SSLv3+for+various+servers+and+client+/18837
Package
Source: nss (LP Ubuntu Debian)
Upstream:released (3.17.1)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (3.17.1-0ubuntu0.12.04.1)
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (2:3.17.1-0ubuntu0.14.04.1)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2:3.17.1-0ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2:3.17.1-0ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (2:3.17.1-0ubuntu1)
Ubuntu 19.10 (Eoan):not-affected (2:3.17.1-0ubuntu1)
Patches:
Upstream:https://hg.mozilla.org/projects/nss/rev/45cb71fd7bca
Package
Upstream:ignored (reached end-of-life)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [6b34-1.13.6-1ubuntu0.12.04.1])
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [6b34-1.13.6-1ubuntu0.14.04.1])
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Package
Upstream:released (7u73)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [7u75-2.5.4-1~precise1])
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [7u75-2.5.4-1~trusty1])
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Package
Source: pound (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.6-6.1)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
More Information

Updated: 2019-10-09 07:50:27 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)