CVE-2014-3251

Priority
Description
The MCollective aes_security plugin, as used in Puppet Enterprise before
3.3.0 and Mcollective before 2.5.3, does not properly validate new server
certificates based on the CA certificate, which allows local users to
establish unauthorized Mcollective connections via unspecified vectors
related to a race condition.
Package
Upstream:released (2.3.5)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected
Ubuntu 19.04 (Disco Dingo):not-affected
More Information

Updated: 2019-01-17 13:14:20 UTC (commit d41a9c5965fa3e038871a57ab5d4caddc4d24778)