CVE-2014-3137

Priority
Description
Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before
0.12.6 does not properly limit content types, which allows remote attackers
to bypass intended access restrictions via an accepted Content-Type
followed by a ; (semi-colon) and a Content-Type that would not be accepted,
as demonstrated in YouCompleteMe to execute arbitrary code.
Notes
Package
Upstream:released (0.12.6-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (0.12.6-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (0.12.6-1)
Ubuntu 19.04 (Disco Dingo):not-affected (0.12.6-1)
Ubuntu 19.10 (Eoan):not-affected (0.12.6-1)
More Information

Updated: 2019-10-18 02:18:09 UTC (commit cccfc4426d8c1fbf582a89d981fe7fc812124543)