CVE-2014-2913

Priority
Description
** DISPUTED ** Incomplete blacklist vulnerability in nrpe.c in Nagios
Remote Plugin Executor (NRPE) 2.15 and earlier allows remote attackers to
execute arbitrary commands via a newline character in the -a option to
libexec/check_nrpe. NOTE: this issue is disputed by multiple parties. It
has been reported that the vendor allows newlines as "expected behavior."
Also, this issue can only occur when the administrator enables the
"dont_blame_nrpe" option in nrpe.conf despite the "HIGH security risk"
warning within the comments.
Notes
sarnoldI marked this 'low' because arguments are discouraged for many
environments, access to NRPE can be restricted with firewalling or
other user access controls, and this might plausibly be a feature.
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.15-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 19.10 (Eoan Ermine):needed
Ubuntu 20.04 (Focal Fossa):needed
More Information

Updated: 2020-01-29 18:18:19 UTC (commit 40f18bf14da5fb50662e1f861ea594a462b207fe)