CVE-2014-2745 (retired)

Priority
Description
Prosody before 0.9.4 does not properly restrict the processing of
compressed XML elements, which allows remote attackers to cause a denial of
service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb"
attack, related to core/portmanager.lua and util/xmppstream.lua.
Package
Upstream:released (0.9.4-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (0.9.4-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (0.9.4-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (0.9.4-1)
Ubuntu 19.04 (Disco Dingo):not-affected (0.9.4-1)
Ubuntu 19.10 (Eoan):not-affected (0.9.4-1)
More Information

Updated: 2019-04-26 14:33:25 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)