CVE-2014-2744

Priority
Description
plugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch
Metronome through 3.4 negotiates stream compression while a session is
unauthenticated, which allows remote attackers to cause a denial of service
(resource consumption) via compressed XML elements in an XMPP stream, aka
an "xmppbomb" attack.
Package
Upstream:released (0.9.4-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (0.9.4-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (0.9.4-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (0.9.4-1)
Ubuntu 19.04 (Disco Dingo):not-affected (0.9.4-1)
More Information

Updated: 2019-01-14 21:15:28 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)