CVE-2014-2324

Priority
Description
Multiple directory traversal vulnerabilities in (1) mod_evhost and (2)
mod_simple_vhost in lighttpd before 1.4.35 allow remote attackers to read
arbitrary files via a .. (dot dot) in the host name, related to
request_check_hostname.
Package
Upstream:released (1.4.33-1+nmu3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.4.35-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.4.35-1ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.4.35-1ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (1.4.35-1ubuntu1)
Patches:
Upstream:http://download.lighttpd.net/lighttpd/security/lighttpd-1.4.34_fix_mysql_injection.patch
More Information

Updated: 2019-01-14 21:15:26 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)