CVE-2014-2287

Priority
Description
channels/chan_sip.c in Asterisk Open Source 1.8.x before 1.8.26.1, 11.8.x
before 11.8.1, and 12.1.x before 12.1.1, and Certified Asterisk 1.8.15
before 1.8.15-cert5 and 11.6 before 11.6-cert2, when chan_sip has a certain
configuration, allows remote authenticated users to cause a denial of
service (channel and file descriptor consumption) via an INVITE request
with a (1) Session-Expires or (2) Min-SE header with a malformed or invalid
value.
Package
Upstream:released (1:11.8.1~dfsg-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1:11.8.1~dfsg-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:11.8.1~dfsg-1ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1:11.8.1~dfsg-1ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (1:11.8.1~dfsg-1ubuntu1)
Patches:
Upstream:http://downloads.asterisk.org/pub/security/AST-2014-002-1.8.diff (1.8)
Upstream:http://downloads.asterisk.org/pub/security/AST-2014-002-11.diff (11)
More Information

Updated: 2019-01-14 21:15:24 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)