CVE-2014-2277

Priority
Description
The make_temporary_filename function in perltidy 20120701-1 and earlier
allows local users to obtain sensitive information or write to arbitrary
files via a symlink attack, related to use of the tmpnam function.
Package
Upstream:released (20130922-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (20140328-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (20140328-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (20140328-1)
Ubuntu 19.04 (Disco Dingo):not-affected (20140328-1)
Patches:
Other:http://git.donarmstrong.com/?p=perltidy.git;a=blob;f=debian/patches/fix_insecure_tmpnam_usage_740670
More Information

Updated: 2019-01-14 21:15:23 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)