CVE-2014-1832

Priority
Description
Phusion Passenger 4.0.37 allows local users to write to certain files and
directories via a symlink attack on (1) control_process.pid or a (2)
generation-* file. NOTE: this vulnerability exists because of an
incomplete fix for CVE-2014-1831.
Notes
 mdeslaur> incomplete fix for CVE-2014-1831
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Patches:
Upstream:https://github.com/phusion/passenger/commit/94428057c602da3d6d34ef75c78091066ecac5c0
More Information

Updated: 2019-01-14 21:15:18 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)