CVE-2014-10064

Priority
Description
The qs module before 1.0.0 does not have an option or default for
specifying object depth and when parsing a string representing a deeply
nested object will block the event loop for long periods of time. An
attacker could leverage this to cause a temporary denial-of-service
condition, for example, in a web application, other requests would not be
processed while this blocking is occurring.
Package
Upstream:released (1.0.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.2.4-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.2.4-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.2.4-1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.2.4-1)
Ubuntu 19.10 (Eoan):not-affected (2.2.4-1)
More Information

Updated: 2019-05-15 17:14:31 UTC (commit 2d71aefac924bf16479c12958688c37878e881eb)