CVE-2014-0477

Priority
Description
The parse function in Email::Address module before 1.905 for Perl uses an
inefficient regular expression, which allows remote attackers to cause a
denial of service (CPU consumption) via an empty quoted string in an RFC
2822 address.
Notes
 mdeslaur> fixes in both 1.904 and 1.905 (and maybe before?)
Package
Upstream:released (1.905-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.905-2)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.905-2)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.905-2)
Ubuntu 19.04 (Disco Dingo):not-affected (1.905-2)
More Information

Updated: 2019-01-14 21:15:15 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)