CVE-2014-0224 (retired)

Priority
Description
OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does
not properly restrict processing of ChangeCipherSpec messages, which allows
man-in-the-middle attackers to trigger use of a zero-length master key in
certain OpenSSL-to-OpenSSL communications, and consequently hijack sessions
or obtain sensitive information, via a crafted TLS handshake, aka the "CCS
Injection" vulnerability.
Assigned-to
mdeslaur
Notes
Package
Upstream:released (0.9.8za,1.0.1h)
Ubuntu 14.04 ESM (Trusty Tahr):released (1.0.1f-1ubuntu4)
Package
Upstream:released (0.9.8za)
Ubuntu 14.04 ESM (Trusty Tahr):released (0.9.8o-7ubuntu4)
More Information

Updated: 2019-10-09 07:49:24 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)