CVE-2014-0130

Priority
Description
Directory traversal vulnerability in
actionpack/lib/abstract_controller/base.rb in the implicit-render
implementation in Ruby on Rails before 3.2.18, 4.0.x before 4.0.5, and
4.1.x before 4.1.1, when certain route globbing configurations are enabled,
allows remote attackers to read arbitrary files via a crafted request.
Package
Source: rails (LP Ubuntu Debian)
Upstream:released (3.2.18, 4.0.5, 4.1.1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2:4.2.6-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2:4.2.10-0ubuntu4)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2:4.2.10-0ubuntu4)
Ubuntu 19.04 (Disco Dingo):not-affected (2:4.2.10-0ubuntu4)
Package
Upstream:released (4.0.5)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
More Information

Updated: 2019-01-14 21:15:12 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)