CVE-2014-0050 (retired)

Priority
Description
MultipartStream.java in Apache Commons FileUpload before 1.3.1, as used in
Apache Tomcat, JBoss Web, and other products, allows remote attackers to
cause a denial of service (infinite loop and CPU consumption) via a crafted
Content-Type header that bypasses a loop's intended exit conditions.
Notes
 mdeslaur> tomcat6 is not affected because access is limited to
 mdeslaur> authenticated admins
Assigned-to
mdeslaur
Package
Priority: Low
Upstream:released (1.3.1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.3.1-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.3.1-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.3.1-1)
Ubuntu 19.04 (Disco Dingo):not-affected (1.3.1-1)
Ubuntu 19.10 (Eoan):not-affected (1.3.1-1)
Patches:
Upstream:http://svn.apache.org/viewvc?view=revision&revision=1565143
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):not-affected
Ubuntu 14.04 ESM (Trusty Tahr):not-affected
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Package
Upstream:released (7.0.52-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (7.0.52-1)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (7.0.52-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (7.0.52-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (7.0.52-1)
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Patches:
Upstream:http://svn.apache.org/viewvc?view=revision&revision=1565169
More Information

Updated: 2019-05-16 12:14:58 UTC (commit 971413b09b767469626a346933253f76df698fa0)