CVE-2013-4852 (retired)

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other
products that use PuTTY allows remote SSH servers to cause a denial of
service (crash) and possibly execute arbitrary code in certain applications
that use PuTTY via a negative size value in an RSA key signature during the
SSH handshake, which triggers a heap-based buffer overflow.
Upstream:released (1.21+ds1-9)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (3.7.3-1ubuntu1)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (3.7.3-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.7.3-1ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (3.7.3-1ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (3.7.3-1ubuntu1)
Source: putty (LP Ubuntu Debian)
Upstream:released (0.63-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [0.62-6ubuntu0.1])
Ubuntu 14.04 LTS (Trusty Tahr):released (0.63-1)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.63-1)
Ubuntu 18.04 LTS (Bionic Beaver):released (0.63-1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (0.63-1)
Ubuntu 19.04 (Disco Dingo):released (0.63-1)
More Information

Updated: 2019-03-26 12:10:14 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)