CVE-2013-4852

Priority
Description
Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other
products that use PuTTY allows remote SSH servers to cause a denial of
service (crash) and possibly execute arbitrary code in certain applications
that use PuTTY via a negative size value in an RSA key signature during the
SSH handshake, which triggers a heap-based buffer overflow.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 18.10 (Cosmic Cuttlefish):needed
Ubuntu 19.04 (Disco Dingo):needed
Package
Source: putty (LP Ubuntu Debian)
Upstream:released (0.63-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [0.62-6ubuntu0.1])
Ubuntu 14.04 LTS (Trusty Tahr):released (0.63-1)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.63-1)
Ubuntu 18.04 LTS (Bionic Beaver):released (0.63-1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (0.63-1)
Ubuntu 19.04 (Disco Dingo):released (0.63-1)
More Information

Updated: 2019-01-14 21:15:00 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)