CVE-2013-4458

Priority
Low
Description
Stack-based buffer overflow in the getaddrinfo function in
sysdeps/posix/getaddrinfo.c in GNU C Library (aka glibc or libc6) 2.18 and
earlier allows remote attackers to cause a denial of service (crash) via a
(1) hostname or (2) IP address that triggers a large number of AF_INET6
address results. NOTE: this vulnerability exists because of an incomplete
fix for CVE-2013-1914.
References
Bugs
Notes
 sbeattie> this fix was also incomplete, leading to CVE-2016-3706
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (2.18-0ubuntu1)
Patches:
Upstream:https://sourceware.org/git/?p=glibc.git;h=7cbcdb3699584db8913ca90f705d6337633ee10f
More Information

Updated: 2017-08-11 23:51:05 UTC (commit 13081)