CVE-2013-2099

Priority
Description
Algorithmic complexity vulnerability in the ssl.match_hostname function in
Python 3.2.x, 3.3.x, and earlier, and unspecified versions of
python-backports-ssl_match_hostname as used for older Python versions,
allows remote attackers to cause a denial of service (CPU consumption) via
multiple wildcard characters in the common name in a certificate.
Assigned-to
mdeslaur
Package
Source: bzr (LP Ubuntu Debian)
Upstream:released (2.6.0~bzr6574)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Trusty/esm:not-affected (2.6.0~bzr6574-1ubuntu1)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.6.0~bzr6574-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.6.0~bzr6574-1ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.6.0~bzr6574-1ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.6.0~bzr6574-1ubuntu1)
Ubuntu 19.10 (Eoan):not-affected (2.6.0~bzr6574-1ubuntu1)
Patches:
Upstream:http://bazaar.launchpad.net/~bzr-pqm/bzr/bzr.dev/revision/6574
Package
Upstream:released (8.5-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Trusty/esm:DNE (trusty was not-affected [8.6-2])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (8.6-2)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (8.6-2)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (8.6-2)
Ubuntu 19.04 (Disco Dingo):not-affected (8.6-2)
Ubuntu 19.10 (Eoan):not-affected (8.6-2)
Package
Upstream:released (2.4.1-3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Trusty/esm:DNE (trusty was not-affected [3.1.1-1ubuntu2])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (3.2.0-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.2.0-1ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (3.2.0-1ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (3.2.0-1ubuntu1)
Ubuntu 19.10 (Eoan):not-affected (3.2.0-1ubuntu1)
Package
Upstream:released (1.6-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:not-affected (1.6-2)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.6-2)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.6-2)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.6-2)
Ubuntu 19.04 (Disco Dingo):not-affected (1.6-2)
Ubuntu 19.10 (Eoan):not-affected (1.6-2)
Package
Upstream:released (2.7.5-5)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code-not-present)
Trusty/esm:not-affected (2.7.5-5ubuntu1)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.7.5-5ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.7.5-5ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.7.5-5ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.7.5-5ubuntu1)
Ubuntu 19.10 (Eoan):not-affected (2.7.5-5ubuntu1)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [3.2.3-0ubuntu3.5])
Trusty/esm:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Patches:
Upstream:http://hg.python.org/cpython/rev/fafd33db6ff6 (trunk)
Upstream:http://hg.python.org/cpython/rev/b9b521efeba3 (3.2)
Upstream:http://hg.python.org/cpython/rev/c627638753e2 (3.3)
Package
Upstream:released (3.3.2-3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Package
Source: w3af (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Package
Upstream:released (2.3.3-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Trusty/esm:DNE (trusty was not-affected [2.3.3-1])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.3.3-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.3.3-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.3.3-1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.3.3-1)
Ubuntu 19.10 (Eoan):not-affected (2.3.3-1)
Patches:
Upstream:https://github.com/0install/0install/commit/0c5b21d47b6007ac764430638a476418688bce16
More Information

Updated: 2019-04-26 14:14:42 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)