CVE-2013-1831

Priority
Description
lib/setuplib.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before
2.3.5, and 2.4.x before 2.4.2 allows remote attackers to obtain sensitive
information via an invalid request, which reveals the absolute path in an
exception message.
Notes
 sarnold> MSA-13-0013
Package
Upstream:released (2.4.2, 2.3.5, 2.2.8)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 18.10 (Cosmic Cuttlefish):needed
Ubuntu 19.04 (Disco Dingo):needed
Ubuntu 19.10 (Eoan):needed
Patches:
Upstream:http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-36901
More Information

Updated: 2019-04-26 14:14:40 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)