CVE-2013-1830

Priority
Description
user/view.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before
2.3.5, and 2.4.x before 2.4.2 does not enforce the forceloginforprofiles
setting, which allows remote attackers to obtain sensitive course-profile
information by leveraging the guest role, as demonstrated by a Google
search.
Notes
 sarnold> MSA-13-0012
Package
Upstream:released (2.4.2, 2.3.5, 2.2.8)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 18.10 (Cosmic Cuttlefish):needed
Ubuntu 19.04 (Disco Dingo):needed
Patches:
Upstream:http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-37481
More Information

Updated: 2019-01-14 21:14:50 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)