CVE-2013-1824 (retired)

Priority
Description
The SOAP parser in PHP before 5.3.22 and 5.4.x before 5.4.12 allows remote
attackers to read arbitrary files via a SOAP WSDL file containing an XML
external entity declaration in conjunction with an entity reference,
related to an XML External Entity (XXE) issue in the soap_xmlParseFile and
soap_xmlParseMemory functions.
Notes
mdeslaurthis CVE is for an incomplete fix for CVE-2013-1643. Our
CVE-2013-1643 did in fact have the complete fix, so we were
not affected by this.
Package
Source: php5 (LP Ubuntu Debian)
Upstream:released (5.4.4-14, 5.3.23, 5.4.13)
More Information

Updated: 2019-10-09 07:45:18 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)