CVE-2013-1629 (retired)

Priority
Description
pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and
does not perform integrity checks on package contents, which allows
man-in-the-middle attackers to execute arbitrary code via a crafted
response to a "pip install" operation.
Package
Upstream:released (1.3.1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (1.5.4-1ubuntu4)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (8.1.1-2ubuntu0.4)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected
Package
Upstream:released (1.9.1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (1.9.1-1)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.9.1-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.9.1-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.9.1-1)
More Information

Updated: 2019-03-26 12:07:11 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)