CVE-2013-1427

Priority
Description
The configuration file for the FastCGI PHP support for lighttpd before
1.4.28 on Debian GNU/Linux creates a socket file with a predictable name in
/tmp, which allows local users to hijack the PHP control socket and perform
unauthorized actions such as forcing the use of a different version of PHP
via a symlink attack or a race condition.
Notes
jdstrandsocket file was /tmp/php.socket. This should be protected by symlink
restrictions in Ubuntu 11.10 and higher
Package
Upstream:released (1.4.31-4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [1.4.33-1+nmu2ubuntu2])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.4.33-1+nmu2ubuntu2)
Patches:
Vendor:http://www.debian.org/security/2013/dsa-2649
This vulnerability is mitigated in part by the use of symlink restrictions in Ubuntu. For more details see https://wiki.ubuntu.com/Security/Features#symlink
More Information

Updated: 2020-03-18 22:11:48 UTC (commit 2ea7df7bd1e69e1e489978d2724a936eb3faa1b8)