CVE-2012-6708

Priority
Description
jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks.
The jQuery(strInput) function does not differentiate selectors from HTML in
a reliable fashion. In vulnerable versions, jQuery determined whether the
input was HTML by looking for the '<' character anywhere in the string,
giving attackers more flexibility when attempting to construct a malicious
payload. In fixed versions, jQuery only deems the input to be HTML if it
explicitly starts with the '<' character, limiting exploitability only to
attackers who can control the beginning of a string, which is far less
common.
Notes
 leosilva> code seems to be quite different.
 mdeslaur> fix is intrusive and backwards-incompatible
Package
Upstream:released (1.11.3+dfsg-1)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Trusty/esm:needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.11.3+dfsg-4)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected
Ubuntu 19.04 (Disco Dingo):not-affected
Ubuntu 19.10 (Eoan):not-affected
Patches:
Upstream:https://github.com/jquery/jquery/commit/05531fc4080ae24070930d15ae0cea7ae056457d
More Information

Updated: 2019-04-26 14:14:39 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)