CVE-2012-5667

Priority
Description
Multiple integer overflows in GNU Grep before 2.11 might allow
context-dependent attackers to execute arbitrary code via vectors involving
a long input line that triggers a heap-based buffer overflow.
Notes
 sarnold> Upstream recommends upgrading to 2.11, but include fixes for two bugs
  introduced in 2.11, and reverting the -r change. See
  oss-security/2012/12/22/3 for details. Upgrading to latest release may also
  make sense.
 jdstrand> Reproducer for amd64 system (tested with 8G of RAM):
  perl -e 'print "x"x(2**31)' | grep x > /dev/null
 jdstrand> Ubuntu 8.04 LTS - 12.04 LTS confirmed to be affected. Each release
  segfaults.
 jdstrand> Ubuntu 12.10+ does not segfault
 jdstrand> RedHat bug has a reduced proposed patch that simply performs
  boundary checking but it has not been commented on as of 2013/05/07
 jdstrand> This is arguably of low priority unless code-execution can be
  demonstrated
Package
Source: grep (LP Ubuntu Debian)
Upstream:released (2.11-1)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Trusty/esm:not-affected
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected
Ubuntu 19.04 (Disco Dingo):not-affected
Ubuntu 19.10 (Eoan):not-affected
More Information

Updated: 2019-04-26 14:14:38 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)