CVE-2012-4481 (retired)

Priority
Description
The safe-level feature in Ruby 1.8.7 allows context-dependent attackers to
modify strings via the NameError#to_s method when operating on Ruby
objects. NOTE: this issue is due to an incomplete fix for CVE-2011-1005.
Notes
 tyhicks> Supplements incomplete fix for CVE-2011-1005
Assigned-to
tyhicks
Package
Upstream:released (1.8.7.358-5)
Patches:
Upstream:http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=37068
Package
Upstream:needs-triage
Package
Upstream:not-affected
More Information

Updated: 2019-03-26 12:04:06 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)