CVE-2012-2652 (retired)

Priority
Description
The bdrv_open function in Qemu 1.0 does not properly handle the failure of
the mkstemp function, when in snapshot node, which allows local users to
overwrite or read arbitrary files via a symlink attack on an unspecified
temporary file.
Assigned-to
mdeslaur
Package
Source: kvm (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Package
Source: qemu (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (1.1~rc+dfsg-1ubuntu9)
Patches:
Other:http://marc.info/?l=qemu-devel&m=133819025731504&w=2
Upstream:http://git.kernel.org/?p=virt/kvm/qemu-kvm.git;a=commit;h=eba25057b9a5e19d10ace2bc7716667a31297169
This vulnerability is mitigated in part by the use of symlink restrictions in Ubuntu. For more details see https://wiki.ubuntu.com/Security/Features#symlink
More Information

Updated: 2019-09-19 15:40:48 UTC (commit d32ebc32606b9517c6fa7d65a15441e2a57a6de5)