CVE-2012-2142

Priority
Description
The error function in Error.cc in poppler before 0.21.4 allows remote
attackers to execute arbitrary commands via a PDF containing an escape
sequence for a terminal emulator.
Notes
jdstrandper Debian, xpdf not affected
mdeslaurneeds a backport
Package
Upstream:released (0.24.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [0.24.0-0ubuntu1])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (0.24.0-0ubuntu1)
Patches:
Upstream:http://cgit.freedesktop.org/poppler/poppler/commit/?id=71bad47ed6a36d825b0d08992c8db56845c71e40
Package
Source: xpdf (LP Ubuntu Debian)
Upstream:not-affected
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
More Information

Updated: 2020-09-10 02:03:51 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)