CVE-2012-2126 (retired)

Priority
Description
RubyGems before 1.8.23 does not verify an SSL certificate, which allows
remote attackers to modify a gem during installation via a
man-in-the-middle attack.
Package
Source: jruby (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected
Ubuntu 19.04 (Disco Dingo):not-affected
Ubuntu 19.10 (Eoan):not-affected
Package
Upstream:released (1.9.3-p194)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [1.9.3.0-1ubuntu2.2])
Trusty/esm:DNE (trusty was not-affected [1.9.3.194-1])
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Patches:
Upstream:http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&sortby=date&revision=35404
Package
Upstream:released (1.8.23)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [1.8.15-1ubuntu0.1])
Trusty/esm:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Patches:
Upstream:https://github.com/rubygems/rubygems/commit/d4c7eafb8efe1e13a7abf5be5a5b4548870b15b7
More Information

Updated: 2019-04-26 14:33:04 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)