CVE-2012-1823

Priority
Description
sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when
configured as a CGI script (aka php-cgi), does not properly handle query
strings that lack an = (equals sign) character, which allows remote
attackers to execute arbitrary code by placing command-line options in the
query string, related to lack of skipping a certain php_getopt for the 'd'
case.
Ubuntu-Description
It was discovered that PHP, when used as a stand alone CGI processor
for the Apache Web Server, did not properly parse and filter query
strings. This could allow a remote attacker to execute arbitrary code
running with the privilege of the web server. Configurations using
mod_php5 and FastCGI were not vulnerable.
Notes
 mdeslaur> Fix was incomplete, see CVE-2012-2311
Package
Source: php5 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):released (5.3.10-1ubuntu4)
More Information

Updated: 2019-01-14 22:02:33 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)