CVE-2011-5057 (retired)

Priority
Description
Apache Struts 2.3.1.1 and earlier provides interfaces that do not properly
restrict access to collections such as the session and request collections,
which might allow remote attackers to modify run-time data values via a
crafted parameter to an application that implements an affected interface,
as demonstrated by the SessionAware, RequestAware, ApplicationAware,
ServletRequestAware, ServletResponseAware, and ParameterAware interfaces.
NOTE: the vendor disputes the significance of this report because of an
"easy work-around in existing apps by configuring the interceptor."
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
More Information

Updated: 2019-04-26 14:33:03 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)