CVE-2011-4862 (retired)

Priority
Description
Buffer overflow in libtelnet/encrypt.c in telnetd in FreeBSD 7.3 through
9.0, MIT Kerberos Version 5 Applications (aka krb5-appl) 1.0.2 and earlier,
Heimdal 1.5.1 and earlier, GNU inetutils, and possibly other products
allows remote attackers to execute arbitrary code via a long encryption
key, as exploited in the wild in December 2011.
Notes
 jdstrand> from DSA: "Kerberos support for telnetd contains a
  pre-authentication buffer overflow".
 jdstrand> did not check if this is protected via stack-protector yet
 mdeslaur> all affected code is in universe binaries
Package
Upstream:released (1.5.2)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (1.6git20120311.dfsg.1-2)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.6git20120311.dfsg.1-2)
Patches:
Vendor:http://www.debian.org/security/2011/dsa-2372
Binaries built from this source package are in universe and so are supported by the community. For more details see https://wiki.ubuntu.com/SecurityTeam/FAQ#Official_Support
Package
Upstream:released (1.9)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected [2:1.8-6])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2:1.8-6)
Patches:
Vendor:http://www.debian.org/security/2011/dsa-2373
Package
Source: krb5 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Patches:
Vendor:http://www.debian.org/security/2011/dsa-2375
Binaries built from this source package are in universe and so are supported by the community. For more details see https://wiki.ubuntu.com/SecurityTeam/FAQ#Official_Support
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Patches:
Vendor:http://www.debian.org/security/2011/dsa-2375
More Information

Updated: 2019-08-23 08:46:11 UTC (commit 436fd4ed4cf0038ddd382cb8649607ace163dda7)